ST ACTD Wiki talk:Bug reports

From ST_ACTD Wiki

Jump to: navigation, search

Contents

Character Importer Issues

Post all the issues you have with the new character importer here. Please be sure to include the exact syntax you used, where you used the syntax from (manually or from here), what kind of problems did you encounter, the serial-number you've used and a link to the ODN character profile in question.

Pending Issues


Solved Issues

  • Sahara Collins is importing with [USS Phobos]] in her assignment history. Should be USS Columbia. --Jafo 18:42, 6 June 2010 (UTC)
    • This should be fixed in ODN. The importer parses the service record. According to that, the character was originally assigned to the Phobos, but never transfered (or reinstated after being inactive) to any other ship. If that is the case, the importer keeps the original ship as that is the most common behavior (e.g. when transferring to another position on the same ship). In the present case, I guess it should be "10905.31: Transferred to CIV aboard USS Columbia". Note that one thing that isn't handled is the case that a ship is re-christened, unless all characters are officially transferred to the new ship. But this is inherently a problem of the underlying data structure. --Sloeffler 08:32, 13 June 2010 (UTC)
      • NOC has corrected this issue and the character has been re-imported. --Jafo 18:01, 20 June 2010 (UTC)


  • Vyse Nyde is importing with no vessel name in his assignment history. Should be PRISM Vanguard. Mierta, same issue. Seems to be all characters assigned to Vanguard. They reverted to previous assignments (or none) with the most recent import. --Jafo 18:42, 6 June 2010 (UTC)
    • This is a feature, not a bug ;). The importer has no notion of what's a valid ship, and what's random garbage (especially when parsing the service record, which contains large portions of free text, AFAIK). Therefore, one has to tell it which ships to look for. This has been made customizable by going to "Special pages -> System messages -> ships". The general syntax is described somewhere in the documentation to the ODNFunctions, I think, but IIRC it is quite simple: "shipname|alias1|alias2|..., ..." where the pipe and aliases can be omitted. Note that no matter which name/alias is found, it will always be shipname that will be imported into the wiki. FYI: there are more such customizable strings, such as "awards", "awards_images", "ranks". --Sloeffler 08:32, 13 June 2010 (UTC)
      • Any thoughts on why it's still not showing under Current Posting? --Jafo 19:41, 13 June 2010 (UTC)
  • Receiving error message "No such special page" when clicking the "update character" tab at the top of each PC page. --Jafo 12:53, 18 October 2009 (UTC)
    • That was annoying... it was when I installed the Forum... I caused a Boo Boot :-) Fixed now. --SchnSilek 13:40, 18 October 2009 (UTC)
  • Take a look at the profile for D'Lareg. The importer is denying updates based on character being an NPC. But, looking at the character history, D'Lareg has had many other positions. Should this update be denied? Also, note that first assignement as XO for Denali Station aboard PRISM:Vanguard (???). That differs from what ODN says. --Jafo 15:01, 27 October 2009 (UTC)
    • Ariel Summers, same issue. --Jafo 15:21, 27 October 2009 (UTC)
      • This will be the policy for any characters with NPC stuff. (Simple 'cause I just invented it.) Any references to NPCs will be removed from inactive characters. (I dig in the ODN to see if I can find them all :-) ) Any active characters with NPC information, will be put inactive with all NPC stuff removed and a replacement "bogus" NPC character will be put there. (Only "bogus" characters will be used for so called mailing list issues). I don't want the wiki to "guess" if this is a "real" character or not. If there is NPC stuff in "real" there, it should be removed. --SchnSilek

Award Issues

Post all the issues you have with the ST:ACTD Awards here. Please be sure to include the award you are having an issue with and a description of what your issue is.

Pending Issues

Solved Issues

Roster Template Issues

Post all the issues you have with the Roster Template, including the auto-update of the template from ODN, here. Please be sure to include the name of the ship you are attempting to update and a description of the problem you are having.

Pending Issues

Solved Issues

  • On the USS Vienna, in the edit section, CIV Kara Xalz shows, however is not displayed on the actual page for the ship - anybody got an idea about that? - sbrengmann, May 29, 2012
    • It seems none of my alterations to the senior staff page of the Vienna seem to work out. Although I added our new XO to the roster today, she, too, doesn't appear on the page. Help? Sbrengmann 13:31, 20 June 2012 (UTC)
    • I managed to solve my XO problem, but the second CIV problem remains... --Sbrengmann 13:28, 6 September 2012 (UTC)
      • This appears to have been resolved. I think it's related to the extra CIV positions but when I updated your roster just now I had no trouble. --Jafo 01:32, 25 September 2012 (UTC)
  • Hey, I updated the roster for the USS Perseus and it came up with two new entries at the bottom. One marked "View Vessel Log Archives" and another marked "View Vessel Website". It looks like these are intended to be links, however they did not populate as such. Also, given that we are talking about redirecting the ship pages to the wiki should we really be adding a "View Vessel Website" link? Would be circular in some instances. --Jafo 13:42, 21 October 2009 (UTC)
    • Those links were added on the ODN. (I've been tweeking a few things there... see if you can find them all. At any rate, I did not know the Vessel Update would grab that. I obviously know now LOL. I fixed it so it does not see those links anymore. --SchnSilek 14:07, 21 October 2009 (UTC)
  • Ren Ro'kar -- This has been an annoyance for a long time. Take a look in All Pages. There is a page for Ren Ro'kar and a page for Ren Ro?kar. Can't seem to make that duplicate go away. --Jafo 14:45, 2 September 2009 (EDT)
    • I just noticed the Scimitar roster was broken after an auto-update from ODN because of the goofie '. That may indicate that the weird character is coming from ODN. --Jafo 21:29, 2 September 2009 (EDT)
      • This bug is giving me trouble... I am still working on it. --SchnSilek 16:59, 12 October 2009 (UTC)
        • THAT was an annoying bug!! First there were 2 versions in the wiki on (Ren Ro'kar and on Ren Ro`kar). In the character importer it grabbed from the ODN Ren Ro`kar many moons ago, then a new version of the character importer changed the ` to a '... but only in the character importer. But the ship roster was looking for Ren Ro`kar not Ren Ro'kar... At any rate... changing Ren Ro`kar to Ren Ro'kar in the ODN directly and deleting the "old stuff finally got this fixed. I'll be going through the database for other "` - ' " problems. --SchnSilek 13:53, 14 October 2009 (UTC)

General Issues

Post all the issues that do not fit in any other category here. Please be sure to include the page(s) your issue appears on and any pertitent information.

Pending Issues

I seem to be having the same problem uploading files that Sascha was a few years ago. Every time I try, I get the message: The upload directory (public) is not writable by the webserver. --Shelwass


Solved Issues

  • All characters assigned to PRISM Vanguard are currently reflecting no vessel in the 'Current Posting' section of the Character Template Sidebar. --Jafo 18:02, 20 June 2010 (UTC)
    • Seems ok here. --SchnSilek 12:57, 7 November 2014 (UTC)
  • While trying to upload the correct logo-jpg-file for the USS Vienna, I received the following error message:"Internal error. The upload directory (public) is not writable by the webserver." --Sascha 11:54, 29 May 2012 (CET)
    • Today, the upload for both a *.jpg and a *.png file worked out, however, when trying to display the logo in the sidebar templat, the error message now is is "Error creating thumbnail: /var/www/html/sites/startrek/www/wiki/bin/ulimit4.sh: line 4: /usr/bin/convert: No such file or directory" Sbrengmann 07:18, 1 June 2012 (UTC)
      • adding my voice to this: Same issue with the USS Kraken logo. "Error creating thumbnail: /var/www/html/sites/startrek/www/wiki/bin/ulimit4.sh: line 4: /usr/bin/convert: is a directory" Aoibhe 19.30, 8 Aug 2012 (GMT)
Finally got this issue fixed. --SchnSilek 12:52, 7 November 2014 (UTC)

Take a look at User Talk:Martin4909 and User Talk:Bapaveza/Welcome. Something about the welcome template is now causing the text in the naviagation bars on the left and top of the page to shrink. --Jafo 17:04, 18 October 2009 (UTC)

  • I thing I know why... I used '{'{welcome|Gilles|------SchnSilek 17:36, 18 October 2009 (UTC) }'}' (I added a quote in between just to show the command ) on my talk page User_talk:SchnSilek and got it correctly... I used it on a SUB-Page User_talk:SchnSilek/Test and got that link '< User talk:SchnSilek' to let me know it's a sub-page. --SchnSilek 17:36, 18 October 2009 (UTC)
    • I don't follow "got that link". What link? I see the side navigation, and top navigation, bars in shrunken text on both your talk page and your sub-page. --Jafo 03:59, 19 October 2009 (UTC)
      • On the top page of the subpage User_talk:SchnSilek/Test .... You'll see small test like this -> '< User talk:SchnSilek' that is a link to say it's a sub page. It has nothing to do with the template. You'll notice the same here: User Talk:Bapaveza/Welcome -> < User talk:Bapaveza The rest of the template is the same... is it not? --SchnSilek 10:41, 19 October 2009 (UTC)
        • Okay, I now understand what you're talking about. That's not what I'm referring to. When I say the top and side navigation bars I'm referring to the links to "Main Page" (side), "Community Portal" (side), "history" (top), "delete" (top), "move" (top). On pages with the welcome template the text of these links is smaller than pages without it - sub pages AND non sub pages. I've seen this both from my work pc and my home pc. If you need further clarification I will upload an image of what I'm seeing later this evening. --Jafo 11:57, 19 October 2009 (UTC)
  • This issue is back. Take a look at the user talk page for Ktinsley and the template page for the welcome template. I found that the template was missing the |} needed to close the table. As a result, when I added a note to Ktinsley's talk page the new note was included in the background. We don't want that. So I added the |} to close the table and suddenly the navigation text was small again. When I mirrored the change on the template page the navigation text shrunk too. --Jafo 15:07, 1 November 2009 (UTC)
    • I added a closing bracket for the div style tag as well as a closing bracket for the table. Once both were in place it seems to be working properly. --Jafo 04:01, 2 November 2009 (UTC)
Personal tools